Problema video su tv crt

Qui trovate tutti i thread riguardanti la risoluzione di problemi di diversa natura. Scrivete qui per ricevere supporto se il vostro problema è generico o non esiste (ancora) la sezione apposita per il sistema con cui avete problemi
Bloccato
mc81
Messaggi: 4
Iscritto il: gio set 19, 2019 4:01 pm
Ha ringraziato: 1 volta
È stato ringraziato: 0

Problema video su tv crt

Messaggio da mc81 » dom set 22, 2019 8:44 am

Buongiorno a tutti, sono appena entrato in questo forum e ne sono rimasto colpito per la generosità degli utenti.
Cercherò di essere più breve possibile.
Un anno fa acquistai già pronto un raspberry p3 b+ con già installato retropie e i giochi per le varie console.
Collegandolo con una tv hdmi tutto perfetto, tranne a dire il vero i giochi per n64 che non sono fluidi ma ho letto che è normale.
Ora, per provare l'emozione grafica degli anni passati ho deciso di far partire il rasp su un vecchio tv crt, precisamente un mivar 14 pollici dotato solo di presa scart.
Tramite cavetto (testato minijack/rca) e adattatore rca/scart, e dopo aver dato qualche modifica al file config.txt ho collegato il tutto.
Ora, il programma all'avvio ha delle presentazioni random, alcune fisse, altre animate.
Se parte la presentazione fissa il tutto si avvia e funziona correttamente, tranne i giochi arcade che risultano un po' più lenti nel video e rallentati anche nell audio.
Se invece parte in random la presentazione animata il tutto risulterà molto rallentato compresi i giochi delle console più leggere, e sono quindi costretto a riavviare.
Spero di essere stato chiaro e che qualcuno possa aver capito da cosa dipende questo rallentamento.
P. S. se c'è bisogno invierò anche il file. txt
Grazie a tutti e scusate ancora il post così prolisso m

Avatar utente
Ionic
Messaggi: 432
Iscritto il: ven giu 03, 2016 9:34 pm
Ha ringraziato: 6 volte
È stato ringraziato: 3 volte

Re: Problema video su tv crt

Messaggio da Ionic » dom set 22, 2019 9:09 pm

mc81 ha scritto:
dom set 22, 2019 8:44 am
Ora, il programma all'avvio ha delle presentazioni random, alcune fisse, altre animate.
Se parte la presentazione fissa il tutto si avvia e funziona correttamente, tranne i giochi arcade che risultano un po' più lenti nel video e rallentati anche nell audio.
Se invece parte in random la presentazione animata il tutto risulterà molto rallentato compresi i giochi delle console più leggere, e sono quindi costretto a riavviare.
Ciao, non è molto chiaro, cosa intendi con "presentazioni all'avvio"?
mc81 ha scritto:
dom set 22, 2019 8:44 am
P. S. se c'è bisogno invierò anche il file. txt
Forse è meglio ;-)

mc81
Messaggi: 4
Iscritto il: gio set 19, 2019 4:01 pm
Ha ringraziato: 1 volta
È stato ringraziato: 0

Re: Problema video su tv crt

Messaggio da mc81 » dom set 22, 2019 9:32 pm

ciao, per presentazioni video intendo quello che succede appena acceso il raspberry, a volte compaiono delle immagini, a volte dei video, in maniera casuale. Dopodichè si avvia il loading dell' emulation station.

Ecco il mio file config.txt:

Codice: Seleziona tutto

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=12
#overscan_right=12
#overscan_top=14
#overscan_bottom=14

# uncomment to force a console size. By default it will be display's size minus
# overscan.
framebuffer_width=800
framebuffer_height=600

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=1
hdmi_mode=21

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#total_mem=1024
#arm_freq=1550
#gpu_freq=500
#core_freq=500
#sdram_freq=500
#sdram_schmoo=0x02000020
#over_voltage=6
#sdram_over_voltage=2
#v3d_freq=525

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on
gpu_mem_256=128
gpu_mem_512=256
gpu_mem_1024=256
overscan_scale=1
gpu_mem=320

Avatar utente
JohnTitor
Messaggi: 180
Iscritto il: mar dic 27, 2016 4:41 pm
Ha ringraziato: 5 volte
È stato ringraziato: 3 volte

Re: Problema video su tv crt

Messaggio da JohnTitor » lun set 23, 2019 7:00 am

Gentilmente puoi leggere questo thread? Ho sistemato io il tuo post.
Assicurati di utilizzare un'immagine ufficiale e nel caso tu non ne sia certo procedi personalmente al download e all'installazione del sistema.
Formatta il tuo post! Inserisci piccoli log in blocchi di codice utilizzando il tag Code mentre per files molto grandi utilizza servizi tipo https://pastebin.com/
Cita i post precedenti in modo intelligente affinché tutto sia sempre leggibile e ordinato. Si vedono post dove per fare una domanda viene quotata un'intera guida o la risposta della risposta della risposta della risposta... il tutto senza nessun valido motivo!
Una TV CRT non arriva a una risoluzione di 800x600, lo standard DVD prevede 720×576 (PAL), tu hai un framebuffer impostato a 800x600, intanto correggi quello. Per il resto se dici che i rallentamenti non sono presenti se colleghi il Raspberry Pi via HDMI il problema potrebbe essere il convertitore, oppure l'impostazione 576i selezionata che non va d'accordo con la risoluzione dei video che devono essere riscalati (e richiedono molta CPU)
Questi utenti hanno ringraziato l'autore JohnTitor per il post:
mc81
Reputazione: 16.67%
Provengo dal 2036...
Nel '75 ho recuperato un IBM 5100 per risolvere un problema del futuro, adesso sono qui perché nel 2038 sarà fondamentale avere più RPi possibile... non posso dirvi il motivo ma nel fratttempo una partita me la faccio! ;-)
_____________________________________________________________
Aiutiamo il forum con una donazione :-)

Hardware:
Raspberry Pi v3 B

mc81
Messaggi: 4
Iscritto il: gio set 19, 2019 4:01 pm
Ha ringraziato: 1 volta
È stato ringraziato: 0

Re: Problema video su tv crt

Messaggio da mc81 » lun set 23, 2019 10:25 am

JohnTitor ha scritto:
lun set 23, 2019 7:00 am
Una TV CRT non arriva a una risoluzione di 800x600, lo standard DVD prevede 720×576 (PAL), tu hai un framebuffer impostato a 800x600, intanto correggi quello. Per il resto se dici che i rallentamenti non sono presenti se colleghi il Raspberry Pi via HDMI il problema potrebbe essere il convertitore, oppure l'impostazione 576i selezionata che non va d'accordo con la risoluzione dei video che devono essere riscalati (e richiedono molta CPU)
Ciao e grazie per i consigli.
Purtroppo pur cambiando la risoluzione non cambia nulla. Ho provato a mettere un cancelletto davanti alle voci hdmi_group e hdmi_mode e non è cambiato nulla.
La cosa strana è che quando l emulationstation si avvia con una semplice immagine e non col video, funzionano bene addirittura i giochi per playstation e psp, mentre gli arcade e neo geo sono lenti nel video e nell'audio.


Avatar utente
Guybrush
Site Admin
Messaggi: 1681
Iscritto il: gio feb 25, 2016 6:33 pm
Ha ringraziato: 12 volte
È stato ringraziato: 14 volte

Re: Problema video su tv crt

Messaggio da Guybrush » lun set 23, 2019 11:11 am

JohnTitor ha scritto:
lun set 23, 2019 7:00 am
...oppure l'impostazione 576i selezionata che non va d'accordo con la risoluzione dei video che devono essere riscalati (e richiedono molta CPU)
mc81 ha scritto:
lun set 23, 2019 10:25 am
La cosa strana è che quando l emulationstation si avvia con una semplice immagine e non col video, funzionano bene...
Direi che forse hai trovato la risposta. In aggiunta l'immagine che usi non è ufficiale (oltre a essere illegale perché già piena di roms), se non hai informazioni sui video che vengono caricati difficilmente possiamo darti una mano. Inoltre non specifichi niente di quello che è scritto qui (thread che sei stato invitato a leggere), ad esempio i files di configurazione responsabili del problema (quelli che lanciano le video presentazioni), così la vedo dura aiutarti
"Dobbiamo costruire computer per le masse, non per le classi" J. Tramiel
_____________________________________________________________
Aiutiamo il forum con una donazione :-)

Hardware:
Raspberry Pi v1 B+ (x2)
Raspberry Pi v3 B

Avatar utente
JohnTitor
Messaggi: 180
Iscritto il: mar dic 27, 2016 4:41 pm
Ha ringraziato: 5 volte
È stato ringraziato: 3 volte

Re: Problema video su tv crt

Messaggio da JohnTitor » mar set 24, 2019 3:12 pm

Come già scritto in passato, se un utente si collega al forum dopo aver ricevuto risposta e nell'arco di 24 ore dalla connessione non fornisce un feedback (anche scrivere "Grazie" oppure "Faccio una prova e vi aggiorno") il thread verrà chiuso perché evidentemente non è interessato a lasciarlo (e noi non siamo più interessati ad aiutarlo).

Aggiunto al fatto che il supporto a immagini di RetroPie non ufficiali non è previsto... si chiude
Provengo dal 2036...
Nel '75 ho recuperato un IBM 5100 per risolvere un problema del futuro, adesso sono qui perché nel 2038 sarà fondamentale avere più RPi possibile... non posso dirvi il motivo ma nel fratttempo una partita me la faccio! ;-)
_____________________________________________________________
Aiutiamo il forum con una donazione :-)

Hardware:
Raspberry Pi v3 B

Bloccato