[RISOLTO] Ambiguità velocità CPU dopo overclock

Qui trovate tutti i thread riguardanti la risoluzione di problemi di diversa natura. Scrivete qui per ricevere supporto se il vostro problema è generico o non esiste (ancora) la sezione apposita per il sistema con cui avete problemi
Bloccato
yohnny
Messaggi: 74
Iscritto il: lun lug 09, 2018 4:32 pm
Ha ringraziato: 3 volte
È stato ringraziato: 1 volta

[RISOLTO] Ambiguità velocità CPU dopo overclock

Messaggio da yohnny »

Buonasera a tutti,
recentemente ho effettuato un overclock di 2.2ghz al mio pi 400, nello specifico sono andato ad editare il file config.txt con questo comando:

Codice: Seleziona tutto

sudo nano /boot/config.txt
e vi ho inserito questi parametri:

force_turbo=1
arm_freq=2200
over_voltage=8

ho salvato e riavviato il tutto, dopodichè provo a verificare la stabilità dell'overclock giocando una partita al Dreamcast, girava decisamente meglio e anche giocando alla lunga non mostrava alcun segno che potesse indicare un malfunzionamento.
Durante il gioco vado a verificare la velocità della CPU in questo modo:

Codice: Seleziona tutto

watch -n 1 vcgencmd measure_clock arm
indicandomi la velocità in tempo reale aggiornata secondo per secondo, dandomi come risultato esattamente 2.2ghz sempre fissi. Tuttavia se vado ad eseguire anche

Codice: Seleziona tutto

lscpu
mi dice 2.394mhz in entrambe le voci della velocità massima e minima della CPU (poiché avevo settato il force turbo), la cosa strana è che ho impostato 2200mhz come massimo e come mai mi va oltre? secondo me è strano.

Mi sono informato in rete e ho notato che è un "problema" che hanno in tanti e da quello che ho visto io nessuno è riuscito a spiegarselo, la stessa cosa se imposto dei parametri diversi sul config.txt ad esempio mettendo overclock a 2.3ghz, ho tentato anche di togliere la stringa "force_turbo=1" per evitare che la CPU stasse sempre fissa al massimo nella speranza che cambiasse qualcosa, purtroppo le cifre che vengono mostrate dai due comandi non combaciano mai, di conseguenza non so due cose: se l'overclock sia riuscito e su quale comando devo fare affidamento.

A qualcuno e capitata questa stessa cosa? non sono molto ferrato in materia
Grazie a tutti!
Ultima modifica di yohnny il mer nov 24, 2021 9:46 pm, modificato 1 volta in totale.

Avatar utente
Guybrush
Messaggi: 2366
Iscritto il: gio feb 25, 2016 6:33 pm
Ha ringraziato: 159 volte
È stato ringraziato: 166 volte

Re: Ambiguità velocità CPU dopo overclock

Messaggio da Guybrush »

Il valore corretto pare sia quello visualizzato dal comando

Codice: Seleziona tutto

vcgencmd measure_clock arm
Questi utenti hanno ringraziato l'autore Guybrush per il post:
yohnny
Reputazione: 10%
"Dobbiamo costruire computer per le masse, non per le classi" J. Tramiel
_____________________________________________________________
Aiutiamo il forum con una donazione :-)

Hardware:
Raspberry Pi Model B Rev 2 (x2)
Raspberry Pi 3 Model B Rev 1.2

yohnny
Messaggi: 74
Iscritto il: lun lug 09, 2018 4:32 pm
Ha ringraziato: 3 volte
È stato ringraziato: 1 volta

Re: Ambiguità velocità CPU dopo overclock

Messaggio da yohnny »

Ah perfetto, gentilissimo grazie mille per la veloce risposta.

Bloccato