[RISOLTO] Rom Neogeo non funzionano

Qui si parla di SNK NeoGeo
Bloccato
Piron88
Messaggi: 2
Iscritto il: mar dic 08, 2020 8:28 pm
Ha ringraziato: 0
È stato ringraziato: 0

[RISOLTO] Rom Neogeo non funzionano

Messaggio da Piron88 »

Salve a tutti
con estremo imbarazzo mi ritrovo ad aprire un post riportante la stessa monolitica domanda "perchè non funzionano le rom neogeo"?

Premetto che ho retropie 4.6 su raspberry 3b+ Ho un archivio con alcune rom neogeo
Ho iniziato con inserirle semplicemente nel percorso \roms\neogeo .... risultato...non funzionano

Ho letto i post sull'utilizzo del mame set builder... quindi ho installato l'applicativo, ho settato la cartella sorgente contenente i romset neogeo, ho definito la cartella di destinazione, ho caricato il file xml del mame2003plus..... risultato? nessuna rom convertita e la cartella di destinazione, che avrebbe dovuto avere le rom convertite, sparita!

Purtroppo non riesco a decifrare questo enigma. Qualcuno di voi saprebbe darmi qualche suggerimento ?

Avatar utente
Guybrush
Site Admin
Messaggi: 2185
Iscritto il: gio feb 25, 2016 6:33 pm
Ha ringraziato: 51 volte
È stato ringraziato: 99 volte

Re: Rom Neogeo non funzionano

Messaggio da Guybrush »

Solo per togliersi il dubbio, domanda numero 10 delle FAQ, controlla il log dopo aver abilitato il verbose logging così possiamo avere dettagli maggiori
"Dobbiamo costruire computer per le masse, non per le classi" J. Tramiel
_____________________________________________________________
Aiutiamo il forum con una donazione :-)

Hardware:
Raspberry Pi B (x2)
Raspberry Pi 3B
Raspberry Pi Zero W
Raspberry Pi 3A+

Piron88
Messaggi: 2
Iscritto il: mar dic 08, 2020 8:28 pm
Ha ringraziato: 0
È stato ringraziato: 0

Re: Rom Neogeo non funzionano

Messaggio da Piron88 »

Guybrush ha scritto:
ven dic 11, 2020 2:47 pm
Solo per togliersi il dubbio, domanda numero 10 delle FAQ, controlla il log dopo aver abilitato il verbose logging così possiamo avere dettagli maggiori
Grazie per aver risposto. Riporto il contenuto del runcommand.log

Codice: Seleziona tutto

Parameters: 
Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-fbneo/fbneo_libretro.so --config /opt/retropie/configs/neogeo/retroarch.cfg "/home/pi/RetroPie/roms/neogeo/mslug.zip" --verbose --appendconfig /dev/shm/retroarch.cfg
[INFO] RetroArch 1.8.5 (Git 8bcd74b)
[INFO] Redirecting save file to "/home/pi/RetroPie/roms/neogeo/mslug.srm".
[INFO] Redirecting savestate to "/home/pi/RetroPie/roms/neogeo/mslug.state".
[INFO] === Build =======================================
[INFO] Capabilities:  NEON VFPv3 VFPv4
[INFO] Built: Apr 20 2020
[INFO] Version: 1.8.5
[INFO] Git: 8bcd74b
[INFO] =================================================
[INFO] Loading dynamic libretro core from: "/opt/retropie/libretrocores/lr-fbneo/fbneo_libretro.so"
[INFO] [Overrides] no core-specific overrides found at /home/pi/.config/retroarch/config/FinalBurn Neo/FinalBurn Neo.cfg.
[INFO] [Overrides] no content-dir-specific overrides found at /home/pi/.config/retroarch/config/FinalBurn Neo/neogeo.cfg.
[INFO] [Overrides] no game-specific overrides found at /home/pi/.config/retroarch/config/FinalBurn Neo/mslug.cfg.
[INFO] [Remaps]: remap directory: /opt/retropie/configs/neogeo/
[INFO] Redirecting save file to "/home/pi/RetroPie/roms/neogeo/mslug.srm".
[INFO] Redirecting savestate to "/home/pi/RetroPie/roms/neogeo/mslug.state".
[INFO] [Environ]: GET_LOG_INTERFACE.
[INFO] Content loading skipped. Implementation will load it on its own.
[libretro INFO] Setting save dir to /home/pi/RetroPie/roms/neogeo/
[INFO] [Environ]: SYSTEM_DIRECTORY: "/home/pi/RetroPie/BIOS".
[libretro INFO] Setting system dir to /home/pi/RetroPie/BIOS
[INFO] [Environ]: SET_CONTROLLER_INFO.
[libretro INFO] DIP switches offset: 25.
[libretro INFO] Initialize DIP switches.
[libretro WARN] Error in mslugDIPList for DIPSWITCH 'Coin chutes': the line '2' is useless
[libretro WARN] Error in mslugDIPList for DIPSWITCH 'Coin chutes': the line '2' is useless
[INFO] [Environ]: RETRO_ENVIRONMENT_SET_CORE_OPTIONS_INTL.
[libretro INFO] [FBNEO] Archive: mslug
[libretro INFO] [FBNEO] Archive: neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name 201-p1.p1 from archive /home/pi/RetroPie/roms/neogeo/mslug
[libretro INFO] [FBNEO] Using ROM with good CRC and name 201-s1.s1 from archive /home/pi/RetroPie/roms/neogeo/mslug
[libretro INFO] [FBNEO] Using ROM with good CRC and name 201-m1.m1 from archive /home/pi/RetroPie/roms/neogeo/mslug
[libretro INFO] [FBNEO] Using ROM with good CRC and name 201-v1.v1 from archive /home/pi/RetroPie/roms/neogeo/mslug
[libretro INFO] [FBNEO] Using ROM with good CRC and name 201-v2.v2 from archive /home/pi/RetroPie/roms/neogeo/mslug
[libretro INFO] [FBNEO] Using ROM with good CRC and name sp-s3.sp1 from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name sp-s2.sp1 from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name sp-s.sp1 from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name sp-u2.sp1 from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name sp-e.sp1 from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name vs-bios.rom from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name sp-j2.sp1 from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name sp1.jipan.1024 from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name sp-45.sp1 from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name japan-j3.bin from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name sp-1v1_3db8c.bin from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name uni-bios_3_0.rom from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name uni-bios_2_3.rom from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name uni-bios_2_3o.rom from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name uni-bios_2_2.rom from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name uni-bios_2_1.rom from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name uni-bios_2_0.rom from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name uni-bios_1_3.rom from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name uni-bios_1_2.rom from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name uni-bios_1_2o.rom from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name uni-bios_1_1.rom from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name uni-bios_1_0.rom from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name sm1.sm1 from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name sfix.sfix from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] [FBNEO] Using ROM with good CRC and name 000-lo.lo from archive /home/pi/RetroPie/BIOS/neogeo
[libretro INFO] DIPSWITCH Neo Geo Mode selected => NeoSystem: 0x00.
[libretro ERROR] [FBNEO] ROM at index 2 with CRC 0x72813676 is required ...
[libretro ERROR] [FBNEO] Can't launch this game, some files are missing.
[ERROR] Failed to load content
[INFO] Content ran for a total of: 00 hours, 00 minutes, 00 seconds.
[INFO] Unloading game..
[INFO] Unloading core..
[INFO] Unloading core symbols..
[INFO] [Core Options]: Saved core options file to "/opt/retropie/configs/all/retroarch-core-options.cfg"
Grazie :?

Avatar utente
Guybrush
Site Admin
Messaggi: 2185
Iscritto il: gio feb 25, 2016 6:33 pm
Ha ringraziato: 51 volte
È stato ringraziato: 99 volte

Re: Rom Neogeo non funzionano

Messaggio da Guybrush »

Piron88 ha scritto:
mar dic 08, 2020 8:48 pm
...ho caricato il file xml del mame2003plus...
Piron88 ha scritto:
dom dic 13, 2020 8:53 pm

Codice: Seleziona tutto

Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-fbneo/fbneo_libretro.so --config /opt/retropie/configs/neogeo/retroarch.cfg "/home/pi/RetroPie/roms/neogeo/mslug.zip" --verbose --appendconfig /dev/shm/retroarch.cfg
Stai usando lr-fbneo, metti quindi i romset nella cartella neogeo, MA provi a creare il set con il file dat di mame2003plus (perché?!?! :? )...

Si può sapere che combini? :lol: Anche facendo il resto correttamente non funzionerebbe
Piron88 ha scritto:
dom dic 13, 2020 8:53 pm

Codice: Seleziona tutto

[libretro ERROR] [FBNEO] ROM at index 2 with CRC 0x72813676 is required ...
[libretro ERROR] [FBNEO] Can't launch this game, some files are missing.
Per quanto riguarda l'errore, controllando questo file dat, pare esser correlato al romset mslug:

Codice: Seleziona tutto

	...
	...
	<game name="mslug" romof="neogeo">
		<description>Metal Slug - Super Vehicle-001</description>
		<year>1996</year>
		<manufacturer>Nazca</manufacturer>
		<rom name="201-p1.p1" size="2097152" crc="08d8daa5"/>
		<rom name="201-s1.s1" size="131072" crc="2f55958d"/>
		<rom name="201-c1.c1" size="4194304" crc="72813676"/>
	...
	...
ovvero il file 201-c1.c1 non è presente nel tuo mslug.zip. Quindi, come volevasi dimostrare, i giochi non si avviano perché i romset che usi non sono giusti.

Innanzitutto con lr-fbneo dovresti usare uno di questi file dat e, considerando che non sbaglia, se MAME Set Rebuilder non crea nessun romset quando fai il rebuilding significa che non è possibile farlo.

Hai letto la Nota sul funzionamento del M.A.M.E. nel primo post del thread dell'applicazione? Il tuo problema evidentemente sta proprio nel set di partenza
"Dobbiamo costruire computer per le masse, non per le classi" J. Tramiel
_____________________________________________________________
Aiutiamo il forum con una donazione :-)

Hardware:
Raspberry Pi B (x2)
Raspberry Pi 3B
Raspberry Pi Zero W
Raspberry Pi 3A+

Avatar utente
JohnTitor
Messaggi: 207
Iscritto il: mar dic 27, 2016 4:41 pm
Ha ringraziato: 11 volte
È stato ringraziato: 5 volte

Re: Rom Neogeo non funzionano

Messaggio da JohnTitor »

Essendo passato un giorno da quando l'utente ha visualizzato la risposta, e visto che nessun feedback è arrivato, deduco che non ci sia più interesse.

In virtù del fatto che il problema iniziale è stato comunque chiarito, chiudo
Provengo dal 2036...
Nel '75 ho recuperato un IBM 5100 per risolvere un problema del futuro, adesso sono qui perché nel 2038 sarà fondamentale avere più RPi possibile... non posso dirvi il motivo ma nel fratttempo una partita me la faccio! ;-)
_____________________________________________________________
Aiutiamo il forum con una donazione :-)

Hardware:
Raspberry Pi v3 B

Bloccato