[RISOLTO] problemi con alcuni giochi

Qui si parla di M.A.M.E.
Rispondi
espolo
Messaggi: 8
Iscritto il: gio ott 08, 2020 11:10 am
Ha ringraziato: 0
È stato ringraziato: 0

[RISOLTO] problemi con alcuni giochi

Messaggio da espolo »

Buongiorno a tutti
Ho installato retropie da poco su una rasp senza problemi, ho svariati giochi funzionanti.
Alcuni però non vanno, Shinobi ad esempio dopo che lo lancio, compare la schermata di configurazione, non premo alcun tasto
(come con gli altri giochi) e poi torna nella schermata di selezione.
Ho provato ad ottenere svariate versioni da siti diversi (naturalmente ho l'originale) ma senza successo.
l'installazione di retropie è "standard" senza alcuna modifica se non il copiare le rom in mio possesso nella corretta cartella.
suggerimenti?
grazie a tutti e buone giocate

Avatar utente
Guybrush
Site Admin
Messaggi: 2045
Iscritto il: gio feb 25, 2016 6:33 pm
Ha ringraziato: 33 volte
È stato ringraziato: 65 volte

Re: problemi con alcuni giochi

Messaggio da Guybrush »

Domande frequenti, numero 33, 25, 16, 38, 37, 41 e 42 da leggere con attenzione in questo ordine
"Dobbiamo costruire computer per le masse, non per le classi" J. Tramiel
_____________________________________________________________
Aiutiamo il forum con una donazione :-)

Hardware:
Raspberry Pi B (x2)
Raspberry Pi 3B
Raspberry Pi Zero W
Raspberry Pi 3A+

Avatar utente
Newton
Messaggi: 265
Iscritto il: gio ago 03, 2017 7:43 am
Ha ringraziato: 15 volte
È stato ringraziato: 12 volte

Re: problemi con alcuni giochi

Messaggio da Newton »

espolo ha scritto:
gio ott 08, 2020 11:27 am
... dopo che lo lancio, compare la schermata di configurazione, non premo alcun tasto
(come con gli altri giochi) e poi torna nella schermata di selezione...
Almeno le domande frequenti, tipo la 10, leggiamole quando ci si iscrive a un forum ;-)
Questi utenti hanno ringraziato l'autore Newton per il post:
Guybrush
Reputazione: 12.5%

Avatar utente
Padremayi
Messaggi: 368
Iscritto il: lun feb 29, 2016 10:10 am
Ha ringraziato: 8 volte
È stato ringraziato: 8 volte

Re: problemi con alcuni giochi

Messaggio da Padremayi »

Newton ha scritto:
gio ott 08, 2020 12:04 pm
Almeno le domande frequenti, tipo la 10, leggiamole quando ci si iscrive a un forum ;-)
Motivo per cui adesso la numero 33 indica di leggere anche la 10 :lol:
"La mente è come un paracadute. Funziona solo se si apre" E. Einstein
_____________________________________________________________
Aiutiamo il forum con una donazione :-)

Hardware:
Raspberry Pi v3 B

espolo
Messaggi: 8
Iscritto il: gio ott 08, 2020 11:10 am
Ha ringraziato: 0
È stato ringraziato: 0

Re: problemi con alcuni giochi

Messaggio da espolo »

Avete perfettamente ragione, completo la domanda:
il gioco in particolare: Shinobi, risulta essere funzionante in mame (ma questo lo saprete già)
Ho già copiato tutto un pacchetto di BIOS diversi (in realtà senza sapere esattamente quale serve perché sul web non ho
ancora trovato shinobi -> questo bios) sia nella cartella home/pi/RetroPie/BIOS che nella cartella delle rom stesse
ma senza successo.

Il file dei log mi dice poco o nulla:

pi@retropie:~ $ tail -f /dev/shm/runcommand.log
Parameters:
Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-mame2003/mame2003_libretro.so --config /opt/retropie/configs/mame-libretro/retroarch.cfg "/home/pi/RetroPie/roms/mame-libretro/mame2003/shinobi.zip" --appendconfig /dev/shm/retroarch.cfg

ora sto provando col Rebuilder


Avatar utente
Guybrush
Site Admin
Messaggi: 2045
Iscritto il: gio feb 25, 2016 6:33 pm
Ha ringraziato: 33 volte
È stato ringraziato: 65 volte

Re: problemi con alcuni giochi

Messaggio da Guybrush »

Prova a controllare il log senza fare un tail, aspetta che torni alla schermata con la lista giochi.

In ogni caso il MAME non ha bisogno di BIOS se non i BIOS che sono romset stessi e che vanno insieme agli altri nella cartella roms dedicata.

Dal log comunque hai appreso che stai usando lr-mame2003, quindi hai bisogno del set versione 0.78.

Il gioco funziona in quella versione del M.A.M.E., il problema è che hai un romset della versione sbagliata, oppure, visto che il log non dice molto, non lo hai messo nella cartella giusta:

Codice: Seleziona tutto

/home/pi/RetroPie/roms/mame-libretro
e il gamelist.xml (lo hai modificato?) fa sì che ti venga mostrato anche se non presente. Non ci sono altri motivi
"Dobbiamo costruire computer per le masse, non per le classi" J. Tramiel
_____________________________________________________________
Aiutiamo il forum con una donazione :-)

Hardware:
Raspberry Pi B (x2)
Raspberry Pi 3B
Raspberry Pi Zero W
Raspberry Pi 3A+

espolo
Messaggi: 8
Iscritto il: gio ott 08, 2020 11:10 am
Ha ringraziato: 0
È stato ringraziato: 0

Re: problemi con alcuni giochi

Messaggio da espolo »

problema risolto, grazie cmq a tutti (anche per avermi ricordato di leggere le faq che rimangono sempre molto molto utili)
cmq il problema è che non avevo mai considerato un romset di una singola versione...
ma recuperando le rom qui e là andando a memoria con i giochi che ricordavo (e che avevo in originale)
alla fin fine ho avuto fortuna, alcune funzionavano, altre di versione diversa...
allineate tutte ora ovviamente funzionano tutte.

grazie ancora

Rispondi